Emergency PSU Replacement
Resolved
Oct 29 at 09:45am CET
Hello there, we've detected that our PSU of multiple systems are currently failing. Therefor we will replace all the Power Supply Units to resolve all issues!
Affected services
Resolved
Oct 29 at 09:45am CET
Hello there, we've detected that our PSU of multiple systems are currently failing. Therefor we will replace all the Power Supply Units to resolve all issues!
Affected services